Unsupported Browser

Scratch Addons doesn't support the browser you're using.

Use updated versions of Chrome, Firefox, or other browsers based on them to get started:


Chromium 80+

System requirements: Windows 7+ OS X / MacOS 10.11+ Chromebooks less than ~6 years old


Firefox 74+

Download How to update

System requirements: Windows 7+ OS X / MacOS 10.9+